Server Requirements

From Starfish ETL
Jump to: navigation, search

The server where the Starfish ETL™ Engine will be installed must have IIS and ASP.NET installed. Microsoft .NET Framework 4.7.1+ is required. For the installation package to function properly on some later operating systems, "IIS 6 Management Compatibility" may also need to be installed.

Any recent 64-bit versions of Windows (7+) or Windows Server (2008+) or newer are supported. If your company supports virtual machines, they can create a basic Windows machine and Starfish ETL™ can be setup on it. Internally, we use virtual machines with a 3 GHZ CPU, 4GB of RAM and a 25 GB hard drive for development. Starfish ETL™ does support multiple cores and multi-threading so having multiple cores can help with performance.

As of Starfish ETL version 5.x+, only 64-bit operating systems are supported.